0

I got this warning while trying to activate the python layer in spacemacs. However, the escape sequences are not unique to this situation; they are usually present whenever there are warnings in the *Warnings* buffer. Why are they there and how do I get rid of them?


OS: macOS 10.13

Emacs Version: 25.3.1

Spacemacs Version: 0.200.9

Shell: zsh (using oh-my-zsh)

.spacemacs: https://pastebin.com/vKVUxFad


*Warnings* Buffer:

Error (use-package): python :init: Invalid version syntax: ‘^[]4;0;rgb:1d/1f/21^[\^[]4;1;rgb:cc/66/66^[^\[]4;2;rgb:b5/bd/68^[\^[]4;3;rgb:f0/c6/74^[\^[]4;4;rgb:81/a2/be^[\^[]4;5;rgb:b2/94/bb^[\^[]4;6;rgb:8a/be/b7^[\^[]4;7;rgb:c5/c8/c6^[\^[]4;8;rgb:96/98/96^[\^[]4;9;rgb:cc/66/66^[\^[]4;10;rgb:b5/bd/68^[\^[]4;11;rgb:f0/c6/74^[\^[]4;12;rgb:81/a2/be^[\^[]4;13;rgb:b2/94/bb^[\^[]4;14;rgb:8a/be/b7^[\^[]4;15;rgb:ff/ff/ff^[\^[]4;16;rgb:de/93/5f^[\^[]4;17;rgb:a3/68/5a^[\^[]4;18;rgb:28/2a/2e^[\^[]4;19;rgb:37/3b/41^[\^[]4;20;rgb:b4/b7/b4^[\^[]4;21;rgb:e0/e0/e0^[\^[]10;rgb:c5/c8/c6^[\^[]11;rgb:1d/1f/21^[\^[]12;rgb:c5/c8/c6^[\6.2.1’ (must start with a number)
1

it seems that zsh is always invoked with full-color ANSI escape sequence „fontification”. This may look nice on a terminal, but plain text modes like the Warnings buffer cannot display those colors. Since I don't use oh-my-zsh, I cannot tell the exact way to remove this setting, but the invocation of zsh has to include the parameter --colors=never or --colors=auto. You should do M-x customize-group oh-my-zsh and find an entry like „zsh invocation”. Alternately, you can generally set zsh to use colors only where appropriate (in its own rc file).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.