1

In Aquamacs, the Emacs for macs, the dictionary can be changed in the Menu by going to Edit -> Spelling -> Change Dictionary...

In my case, I enter en_GB. How do I avoid doing this for every file again every time I open it? Where can I set this permanently as the default for all files?

I suppose I need to add a line in Preferences.el - but which one?

Neither of these two lines work

(setq ispell-dictionary "en_GB")

(setq ispell-dictionary "british")
1

There's a variable called ispell-dictionary, whose docstring you can see with C-h v ispell-dictionary (note that you can use completion there, so this is a way to find variables named ispell-something).

ispell-dictionary is a variable defined in ‘ispell.el’. Its value is "francais" Original value was nil

Documentation: Default dictionary to use if ‘ispell-local-dictionary’ is nil.

You can customize this variable.

Click (or type enter) on the customize link to customize its value. In the customize buffer, you will be able to change its value and save it through the State button.

  • I am confused. In my case it is indeed set to en_GB, but when I type "colour", it still shows an error, and when I type "color" it shows none. Is there a different dictionary for flyspell? Or is it the same? – Realbeginner Sep 30 '17 at 14:23
  • 2
    I finally found out that on OSX, the operating system overrides the EMacs settings and checks the spelling with its own setting. Your answer was correct - thank you! – Realbeginner Sep 30 '17 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.