I probably hit the wrong keys at some point but now when I'm calling an org-agenda command (i.e. C-a a), I'm receiving an error message: Invalid duration format: "shell", with an empty window. I re-installed org-mode with no success.

org-mode 9.1.2

emacs 25.3

Ubuntu 17.04

  • Not enough information to go on. It's probably something malformed in whatever file(s) you have as your agenda files. Go to those files and search for "shell." If that doesn't yield anything, recursively bisect the agenda files (comment out half, then half of half, etc.) until you identify the malformed line(s).
    – Dan
    Oct 12 '17 at 14:08
  • Thanks @Dan! Indeed, there was a property in one of the agenda item which had the word "shell" inadvertently inserted. Removing it solved the issue.
    – Denis
    Oct 12 '17 at 14:41
  • Great! Could you write up a description of what you did to resolve the issue, post it as an answer (it's fine to answer your own questions!), and then accept it once the system lets you do so?
    – Dan
    Oct 12 '17 at 14:42

The word "shell" was inadvertently inserted into a PROPERTIES drawer in one of the entry of an org agenda file. Removing it solved the issue.


To help identify the element which is causing trouble, run the org-agenda command but restricting to particular files and particular subtrees


I also did what the OP has done. I also received the error message: Invalid duration format "taTesting" I also re-installed EMACS, org-agenda, etc to restore my emacs configuration

Two hours of toil passed --and the problem didn't go away--

What solved the problem was: M-x dired and navigated to the folder containing my .org files

M-x grep-find , entered taTesting

BANG! It found a grep match.

I go to that location and remove the :Effort: property containing that offensive value, and saved that file.

org-agenda behaved properly from then on.


I got a similar error Invalid duration format: "-" when I was opened my agenda. Let me complete @Denis answer by explaining how this malformed input can be "inadvertently" inserted. In my case, the reason behind is I have mistakenly input "-" in the effort buffer activated on the agenda (e in the agenda). At the time, I've received the same error Invalid duration format: "-" but - has still been written in my agenda file. It was more painful to find "-" than "shell" since it appears everywhere in an agenda file. I will report this behaviour.

Sidenote: Org-mode 9.1.9.


The issue is fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.