I've installed Emacs via Homebrew. The version that got installed is 25.3.1. It was installed as the file whose full path is /usr/local/bin/emacs. When I execute


at a Terminal window, Emacs starts inside the self-same window as a console application. How can I cause it to start as a GUI application?

The answer given here won't work, because the version of Emacs installed as /Applications/Emacs is 25.1.1 .

macOS Sierra Version 10.12.6

  • If you don't like the end result of what other answers posted, you can just try xemacs instead :) Dec 18, 2019 at 23:22
  • brew install --cask emacs installs Emacs.app, and brew install emacs installs emacs without GUI into /opt/homebrew/Cellar/emacs
    – DawnSong
    May 12, 2022 at 13:59

3 Answers 3


Did you follow the install instructions in the wiki?


Basically, you need to install it with cocoa, it adds the GUI support.

$ brew install emacs --with-cocoa

If you are willing to use spacemacs, then they recommend installing emacs-plus. https://github.com/syl20bnr/spacemacs

$ brew tap d12frosted/emacs-plus
$ brew install emacs-plus
$ brew linkapps emacs-plus
  • Thank you so much! Where is it recommended to install emacs-plus?
    – Evan Aad
    Oct 14, 2017 at 15:23
  • 1
    If you use Spacemacs on OSX, the documentation suggest you install emacs-plus. Oct 14, 2017 at 15:26
  • The required command is now brew install --cask emacs (as noted in a comment above that I missed on first glance)
    – Digicrat
    Jul 6, 2023 at 22:44

According to Emacswiki "Homebrew has Emacs 26.1 as of January 2019" and "Homebrew now recommends to use the cask version".

The message that Homebrew gives is "Please try the Cask for a better-supported Cocoa version".

I tried --with-cocoa myself in February 2019 and is not supported any more.

linkapps also doesn't work any more.

Use this command to install Emacs with Cocoa.

brew cask install emacs

This works for Emacs 26.1 upwards.

The command brew cask install was changed to brew install --cask instead. You will get a warning for now, but it might lead to errors in the future. Use the following command instead.

brew install --cask emacs
  • Thanks. What is your answer based on? Could you link to a source, please?
    – Evan Aad
    Feb 12, 2019 at 19:06
  • Added some sources :)
    – ayckoster
    Feb 13, 2019 at 8:29
  • Great. Thanks. +1
    – Evan Aad
    Feb 13, 2019 at 12:11
  • Same experience as ayckoster. Confirming that it worked for me a/o Apr 30. 2019.
    – tomilchik
    Apr 30, 2019 at 15:06
  • 1
    brew install --cask emacs worked for me. Thanks
    – A. K.
    Oct 7, 2021 at 23:11

Even though I use brew, I find it easier to directly download and install emacs from the official website due to these GUI issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.