2

I have a question that might be unique. I am new to emacs, so please forgive me (or point me in the right direction) if I missed something obvious or say something wrong.

My problem is that I have made my echo-area a darker color than its surrounding, and now I can see a gap on the sides of the echo area. If I could color that area, or delete the padding/border that is causing that gap, or anything else to remedy the situation, I would be happy to hear it.

I will attach a picture and provide some potentially not useful context below.

I have disabled my mode-line, and I am using the symon package to put the mode line info in the echo area.

I have colored the echo-area using

(with-current-buffer " *Echo Area 1*" (face-remap-add-relative 'default :background "#222"))

and it only (currently) colors the idle mode.

I am using the "doom-one" theme from the "doom-themes" package. The picture shows the left side but both sides have this gap.

Let me know if there is any other info I should provide. Thank you for your time!

my emacs corner

i made a red one to make the problem more visible

1

Aha! It was the fringe. This question had the answer:

How to disable margin inside a frame

and setting (fringe-mode 0) seems to solve it, though I wish there was a way to only turn off the fringe in the echo-area, or have the echo-area overlap it or something.

  • You can accept your own answer. – Drew Oct 18 '17 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.