1

I get the following error when trying to amend a commit (same if I try to make a new commit):

  1 git … commit --amend
*ERROR*: Terminal type "dumb" is not powerful enough to run Emacs
error: There was a problem with the editor 'emacsclient -t'.
Please supply the message using either -m or -F option.

It was working earlier, the only thing I remember changing was trying out magit-gerrit. I removed that since and still doesn't work.

emacsclient -t works from the command line.

Magit 20171015.2104, Git 2.13.0, Emacs 24.4.2, gnu/linux

2

OK, looks like I already solved it: git config --list --global contained core.editor=emacsclient -t. After removing -t it is working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.