0

I just installed a fresh Ubuntu 17.10 on a Dell XPS 15, and then installed Emacs from the repos with apt-get in the normal way.

The moment I start Emacs, I get the error message

Error running timer 'blink-cursor-start': (wrong-type-argument listp 0.5)

It then refuses all keyboard input; for example C-x d gets the error message Wrong type argument: listp 10

Is there a way to disable (from outside Emacs) whatever it is that calls blink-cursor-start so that I can at least try using Emacs to find and fix the problem? I have not installed my .emacs file yet, so this is raw behaviour as-installed.

Has anyone seen this behaviour before? Or know what the problem might be?

[Edit] I managed to run Emacs without the suggested -Q just enough to open the messages buffer with the mouse and grab the contents. Then quit and run again with -Q and paste the message contents into a file to save it. This is what it says:

Loading 00debian-vars...done
Loading /etc/emacs/site-start.d/50asymptote.el (source)...done
Loading /etc/emacs/site-start.d/50autoconf.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done
Loading debian-ispell...done
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done
Loading /etc/emacs/site-start.d/50latex-cjk-common.el (source)...
Loading cjk-enc...done
Loading /etc/emacs/site-start.d/50latex-cjk-common.el (source)...done
Loading /etc/emacs/site-start.d/50latex-cjk-thai.el (source)...done
Loading /etc/emacs/site-start.d/50texlive-lang-english.el (source)...done
For information about GNU Emacs and the GNU system, type C-h C-a.
setq: Wrong type argument: listp, 10
Error running timer ‘blink-cursor-start’: (wrong-type-argument listp 0.5) [2 times]
setq: Wrong type argument: listp, 0.7
Error running timer ‘blink-cursor-start’: (wrong-type-argument listp 0.5) [5 times]
Mark set
Error running timer ‘blink-cursor-start’: (wrong-type-argument listp 0.5)
setq: Wrong type argument: listp, 0.7 [2 times]
Error running timer ‘blink-cursor-start’: (wrong-type-argument listp 0.5)
setq: Wrong type argument: listp, 0.7
Error running timer ‘blink-cursor-start’: (wrong-type-argument listp 0.5) [4 times]

Anyone know where blink-cursor-start is called?

12
  • 4
    Does it also happen with emacs -Q
    – Dan
    Commented Nov 4, 2017 at 0:58
  • Cool, thank you. It comes up just fine that way. Weird -- in all my decades of using Emacs I've never had to use -Q or even noticed it existed. It's equivalent to --no-splash, which is fine; and also to --no-site-file --- which 'site-file' does this refer to? The system-wide init.el? Some other init.el? Or the debian-startup.el (I'm using Ubuntu)? Or my own .emacs? I'm interested in tracking down whatever has been broken in this release Commented Nov 5, 2017 at 12:14
  • I just edited the original to add the log of startup echoes in messages. Commented Nov 5, 2017 at 15:43
  • With regards to your question as to whether anyone knows where blink-cursor-start is called, a quick grep of the source code should give you all references. And, we can see that is only called one time in frame.el at the tail end of blink-cursor--start-idle-timer. Since all current versions of Emacs have blink-cursor-mode enabled by default, it is reasonable to assume that you have a user-configuration somewhere that is loading and causing the problem, or you have a broken installation of Emacs. If it is not a big deal, then just remove your Emacs installation and build a new one.
    – lawlist
    Commented Nov 6, 2017 at 1:33
  • Also, verify the version of Emacs that you are using with M-x emacs-version. Some computers may have several versions installed at different locations, and people think they are using one version when in fact they are using a different version. If there is no good reason to use an older version of Emacs, then you should be using the latest stable release -- i.e., Emacs 25. The next version (Emacs 26) will hopefully be released soon. Creating a recipe starting from emacs -Q is necessary so that others can replicate your issue and also for you to verify configuration is not the culprit.
    – lawlist
    Commented Nov 6, 2017 at 1:37

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.