1

I had my GUI emacs installed by brew cask install emacs.

I wanted to strictly check the downloaded package, by its signature, so I put following (as for testing, solely) in ~/.emacs.d/init.el:

(require 'package)
(setq package-check-signature t)

When try to install any package (from elpa) by the package interface of M-x list-packages, it results in message of epg-context--make: GPG error: "no usable configuration", OpenPGP, and cannot install.

Question

  • How can I configure the init.el so that I can turn on package-check-signature and install packages?

Env

  • GNU Emacs 25.3.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 10.9.5 (Build 13F1911))
  • OS X El Capitan
0

It turned out that, I needed to install OpenGPG separately.

brew install gnupg

solved this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.