1

I have an ASCII-armored GPG file that I open with a bookmark, and lately emacs has taken to opening it without asking for the passphrase, even if I just started emacs. I can't remember if I used symmetric encoding or my key. epa-file-cache-passphrase-for-symmetric-encryption is set to nil, gpg-agent isn't installed, and I don't think Gnome is caching it. So what gives? Thanks in advance.

2

How can you be sure that GNOME is not caching the passphrase? If you are starting emacs in non-terminal mode, and if it is not asking for passphrase, you must have checked the option for "Automatically unlock whenever I am logged in".

You can start seahorse from the GNOME search bar or from the terminal and go to your Gnome2 Key Storage and search for gpg2 key passphrase and delete it from there. After that emacs should ask you for your gpg2 passphrase.

| improve this answer | |
  • This seems to have worked - I'm embarrassed. I thought I had disabled that previously. In my defense I feel like emacs used to ask in the minibuffer, not through gnome? I couldn't see how to do it through seahorse though - I had to use dconf-editor as suggested in this Ubuntu answer. Anyway thanks! – Steve Petersen Nov 22 '17 at 0:55
  • Its challenging to get .authinfo.gpg/.netrc, gpg-agent, seahorse, and emacs to all play nicely. You might check out pinentry emacs to input passphrase in the minibuffer: github.com/ecraven/pinentry-emacs – SeaDude Nov 30 '17 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.