0

Emacs prelude "smartens" C-a by rebinding it to "crux-move-beginning-of-line"

My muscle memory likes the vanilla emacs setting better, where C-a moves point to the absolute beginning of the line.

How do turn off this specific prelude "smarts". ?

2

You can use that:

(global-set-key (kbd "C-a") 'move-beginning-of-line)

Since this is defined on prelude-mode, you can alternatively redefine this directly for this minor mode map:

(define-key prelude-mode-map (kbd "C-a") 'move-beginning-of-line)

If you don't want write any additional setup on your init file, as ultimate alternative you can just disable prelude-mode by M-x prelude-mode, but if you are using prelude I don't see this is as good thing, but you can anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.