3

Last week I had to abort a rebase in magit. Soon after my computer became unstable so I rebooted.

Today, when I do C-x g for magit-status, I get an error in the status line

Setting current directory: No such file or directory, /Users/user1/project/subproject/.git/rebase-merge/

Instead of the magit-status display, I get an empty window. The mode line indicates

0   1: 0 UU-R-*magit: subproject                             All Magit company EditorConfig +  

So far, I tried

$ brew services stop emacs
Stopping `emacs`... (might take a while)
==> Successfully stopped `emacs` (label: homebrew.mxcl.emacs)
$ brew services start emacs
==> Successfully started `emacs` (label: homebrew.mxcl.emacs)
$ alias emacs
alias emacs='emacsclient -nw'
$
  • Can you fix it via the git command line tools? – Dan Nov 27 '17 at 14:23
  • git command line shows no issues. git status shows all clear. – american-ninja-warrior Nov 27 '17 at 14:33
  • Try git rebase --abort. – tarsius Nov 27 '17 at 14:51
  • tried it. git command line says theres no rebase in progress. – american-ninja-warrior Nov 27 '17 at 14:53
  • And HEAD is not detached? If so delete .git/rebase-merge, .git/rebase-apply. Otherwise also try a git cherry-pick --abort. – tarsius Nov 27 '17 at 14:56
4

I had the same symptoms after doing a rebase. I'm not sure exactly what happened; I started an interactive rebase in magit and, I think, switched away from the revision rearrangement screen (the git-rebase-todo buffer) and forgot that I had a rebase going on and did other things.

The problem turned out that there was an open buffer visiting

.git/rebase-merge/git-rebase-todo

After closing this buffer, magit no longer tried to access the non-existent rebase-merge directory.

1

brew uninstall emacs and then reinstalling fixed it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.