0

When I try to open an *.org file that I have previously created and saved, Emacs only displays the first line of the file in the buffer. I load the file with C-x C-f. I witnessed this behavior for org files only. When I open the org file with another editor (sublime, notepad, etc...) the whole data is there so the file itself seems fine. Could not find any documentation on this behavior.

  • Exporting to html works, I should add, even though I don't see the whole content in emacs itself. – kimsay Dec 5 '17 at 21:34
  • 1
    Apologies if this is obvious - not sure how new you might be to Org mode - but by default an org file is opened with the outline tree collapsed (see org-startup-folded). Can you just hit tab on that first line to expand the tree? – glucas Dec 5 '17 at 21:56
  • @glucas You don't have to apologize, because exactly that was the case. I am completely new to org-mode (and emacs). – kimsay Dec 5 '17 at 22:30
  • Ah - glad to help then! I'll turn my comment in to an answer so you can resolve this question. – glucas Dec 5 '17 at 22:32
1

This is the expected behavior: by default, org files are opened in a folded overview state. You can use TAB (bound to org-cycle) to expand the outline tree.

If you prefer your Org files to open in an already-expanded state, you can either customize the startup behavior:

M-x customize-option org-startup-folded

Or you can control this per Org file by adding something like:

#+STARTUP: nofold

(See Visibility Cycling in the Org manual for more.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.