1

I just put (setq ido-use-virtual-buffers t) in my init file. It seems ido virtual buffers includes my bookmarks after I use bookmark-jump.

How could I make ido virtual buffers only includes my recent files?

1

I think I found the solution, but I don't know if it will break something. So far, it works fine.

(defadvice ido-add-virtual-buffers-to-list (around k--advice-remove-bookmarks activate)
  (let ((bookmark-alist ()))
    ad-do-it))

Equivalently, with the newer advice-add mechanism:

(define-advice ido-add-virtual-buffers-to-list
    (:around (fn &rest args) my-disable-bookmarks)
  "Call FN on ARGS with bookmarks temporarily disabled."
  (let ((bookmark-alist ()))
    (apply fn args)))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.