In Aquamacs 3.3, ESS 16.04, I can't get customizations added to ess-mode-hook to run. Here's a simple example.

(defun my-ess-hook ()
  (setq ess-default-style 'DEFAULT)
  (setq ess-indent-level 2))
(add-hook 'ess-mode-hook 'my-ess-hook)

I put this code in Preferences.el, saved the file, quit Aquamacs, relaunched Aquamacs, opened an R file, and no joy - the indent level was not changed. What am I doing wrong?

  • Did you load your file Preferences.el (before using ess-mode)? – Drew May 6 '18 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.