0

I am on Mac OS X El Capitan.

Here is my version info. GNU Emacs 25.3.1 (x86_64-apple-darwin15.6.0, NS appkit-1404.47 Version 10.11.6 (Build 15G31)) of 2017-12-03

Problem: Like most Emacs users on Mac OS I have remapped Meta to . So now when I try to do isepll-word by doing M - $ it goes into screen capture mode of Mac OS. (The way to take a screen capture of a selected portion of your screen is to do shift - ⌘ - 4), which unfortunately is the same as M - $.

Question? I when I am in Emacs I want to be able to M - $ and go into the choices for spellings. I know that I can enter this as an extended command as M-x: ispell-word. But I'd rather be able to do this with the keyboard shortcut.How can I fix this?.

  • It sounds like the key binding is intercepted by the OS before it ever reaches emacs. – Dan Dec 30 '17 at 2:38
  • Yes, you are right. The key binding gets intercepted by the OS before it reaches emacs. I have installed emacs via brew install emacs – minibuffer Dec 30 '17 at 4:55
  • This looks like an OS issue rather than an emacs issue. You need to turn off the key binding at the OS level. – Dan Dec 30 '17 at 11:26
  • 1
    You can always type ESC $, which shouldn't cause the problem. Maybe there's a way to rebind screen capture in macOS? – DoMiNeLa10 Dec 30 '17 at 13:14
  • Yeah, I guess I will go ahead and use ESC $ for nowuntil I figure out a better alternative. I am certainly not going to mess with turning off apple-key at the OS level. – minibuffer Dec 31 '17 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.