3

I currently have my mu4e setup and working properly, except for one thing. Using the "U" key in mu4e in emacs does not seem to retrieve the emails using mbsync. I am using spacemacs (in case that is relavent).

This is my emacs configuration:

(defun dotspacemacs/user-config ()
  (setq mu4e-reply-to-address "my.email@website.com")
  (setq mu4e-get-mail-command "mbsync -a")
)

The interesting part is that when using the "U" keybinding, mu4e does index my new emails, but it does not retrieve them, despite having set the mbsync command above.

It should be noted that when I run mbsync manually from my terminal I am able to retrieve the new emails successfully (I first send an email from another account, run mbsync from terminal, then index from mu4e, and all is well), so my wager is that something is incorrectly configured within mu4e itself, and not mbsync. I will also note that my mail directory is set at ~/Maildir/ within my mbsyncrc configuration file.

What steps could I take to retrieve emails using the mu4e "U" keybinding using mbsync?

  • AFAIK mu can't index messages that were not downloaded. How can you tell they were not retrieved? – YoungFrog Jan 3 '18 at 9:35
  • @YoungFrog, I can tell that the messages are not retrieved from mu4e because I run the "U" keybinding (which indicates no new messages in my inbox) then I proceed to run mbsync manually from the terminal using mbsync -a, which then indicates a new message received (in this case a test message sent from another email account). The question has been edited for clarity. – Bryce Frank Jan 3 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.