0

When I use magit on a RHEL 7 box today, it gives me this output when checking magit-status:

magit-status output

Not sure what went wrong. Magit-version output is:

Magit 2.11.0, Git 2.14.1, Emacs 25.3.1, gnu/linux

The same Emacs setting works on Mac without any issue, haven't checked with a different Linux box yet.

Has anyone encountered the same problem before?

Thanks.

Edit:

Found the problem, thanks to icarus. Sometime ago, I added

[color] ui = always

in my ~/.gitconfig. That's cause for all these control characters to show up. Removing it fixed it.

  • 1
    Identical ~/.gitconfig files on the two machines? Does removing ~/.gitconfig help? – icarus Jan 11 '18 at 6:35
  • Ah ha, yes, it's because the [color] ui = always setting in ~/.gitconfig Thanks – sudo Jan 11 '18 at 20:04
  • @sudo Instead of appending the answer to the question itself please turn it into an actual, stand-alone answer. You can then accept your own answer and the question does not forever remain unanswered. – tarsius Jan 11 '18 at 21:00
  • @tarsius Cool, got it. – sudo Jan 12 '18 at 21:11
1

The two different machines had different ~/.gitconfig files, in particular one had an option selecting color always rather than when the output was going to the terminal. The ^[[32m and similar are ansi terminal color selecting sequences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.