4

Just noticed this message after emacs startup "Package assoc is obsolete!", but everything seems to work nice. The requirement seems to be called by yasnippet only.

I just want to know if I should do something to fix this warning.

  • You might be interested in this emacs-devel@gnu.org thread. – Drew Nov 22 '14 at 21:29
5

No, you don't need to do anything. Actually, you can't even do anything about it without patching the source of the affected package.

Generally, as a user you don't need to be concerned about warnings. Only if you actually develop packages, you should care about warnings in your packages, and try to fix them.

However, if you like to, you can report the warning to the YASnippet maintainers to make them aware of the warning, and get them to update their code, but it's by no means necessary.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.