0

When I open this file in emacs

https://raw.githubusercontent.com/limist/literate-programming-examples/master/01-clojure-literate-ants/literate-ants.org

Screenshot of the org file in Emacs showing indentations

I see emacs is showing me ** lines as *** lines.

Whats the logic behind this?

Update: I noticed the file has a heading like this
#+STARTUP: align indent fold nodlcheck hidestars oddeven lognotestate

2
  • When I open this file with no custom org configuration (e.g. emacs -q), I don't see the same thing. The STARTUP line you mention is enabling org-hide-leading-stars, which means I only see one * per heading, just indented to the correct level. Have you customized org mode in some way? A theme that changes the org-hide face might also be a factor.
    – glucas
    Jan 16, 2018 at 19:57
  • 1
    The STARTUP line also sets oddeven, but it looks like perhaps you are using org-odd-levels-only? Even then you would have to explicitly convert the file (see org-convert-to-odd-levels). Opening an existing file and switching to odd levels only would not actually change the file. Things I would try: Switch to text-mode, do you see 2 or 3 stars there? If 2, then look at org appearance / theme settings. If 3, then the file has been modified, possibly by org-convert-to-odd-levels. I'd also try starting emacs with -q and see if the behavior is different.
    – glucas
    Jan 16, 2018 at 20:08

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.