10

When I try enter commands via C-x, it takes 1-2 seconds until the echo area shows this prefix key, as C-x-. I'm quite new to Emacs, so this often confuses me, and I get lost.

The ESC key acts similar to this, so when I try to escape out of some half-entered command, I often end up looping pressing ESC and again after 1-2 second I see ESC- in the echo area.

Is there a way to decrease the time it takes to show a reaction in the echo area, am I doing something wrong, or is this somehow intended?

12
(setq echo-keystrokes 0.01)

will result in near-instantaneous echoing of the keystrokes. Alternatively, you could customize the variable (M-x customize-variable RET echo-keystrokes).

The variable determines the delay, in seconds, before echoing unfinished commands. If the value is 0, then do not echo at all (which is why you need to choose a very short delay, like 0.01 s).

  • 1
    works perfectly - are there any downsides/is there a reason for echo-keystrokes to be 1 initialy? – kai-dj Jan 28 '18 at 18:32
  • 1
    Not sure why — possibly to avoid clutter/over-verbosity when somebody presses the keys quickly. Neither the docstring of the variable (C-h v) nor the info manual list any downsides: gnu.org/software/emacs/manual/html_node/elisp/… – aplaice Jan 28 '18 at 18:38
  • 1
    great – thank you! will keep it .01sec then until I don't get lost anymore and eventually be annoyed by the clutter ^^ – kai-dj Jan 28 '18 at 18:43
  • 2
    "is there a reason for echo-keystrokes to be 1 initialy" I would guess that it is a legacy setting. On a slow terminal you wouldn't want to waste bandwidth echoing commands that the user doesn't need to see. – dmckee Jan 29 '18 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.