1

I have set the org-clock-mode-line-total to be 'today as shown in the line from my custom.el

'(org-clock-mode-line-total (quote today))

When I have a task where I had some spent some time yesterday (Monday) and I start clocking it today(Tuesday), the amount of time that I spent from yesterday seems to be included in the mode line total.

e.g. current time is 7:45 am on Tuesday for the task shown below and my modeline total is shown to be 0:55.

**** STARTED Port over additions/changes to the real project.
:LOGBOOK:
CLOCK: [2018-01-30 Tue 07:35]
CLOCK: [2018-01-30 Tue 07:20]--[2018-01-30 Tue 07:30] =>  0:10
CLOCK: [2018-01-30 Tue 07:20]--[2018-01-30 Tue 07:25] =>  0:05
CLOCK: [2018-01-29 Mon 16:25]--[2018-01-29 Mon 16:55] =>  0:30
:END:

If I manually change Monday's log book entry to make it Sunday, the time shown on the modeline becomes correct(i.e. 0:20) . Maybe I have a wrong option setting somewhere? Any suggestions?

1

Update: This seems to have been a bug which was fixed in a newer git commit. https://code.orgmode.org/bzg/org-mode/commit/0790855c93533ce988f5b28839fdf0eca7521ad3

After some investigation, it appears that this may have to do with org-mode using UTC midnight to midnight to be "today" as opposed to midnight as defined by my local time zone (PST). This problem goes away after setting 'org-extend-today-until' to 8 which is the difference between UTC and my time zone.

Not clear if it is a bug or incorrect setup with org-mode, emacs or something else. I started emacs with -q to not load my init file. org-mode was from the git head for today (Feb 1, 2018) and unaltered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.