5

CEDET Version: 2.0 I have EMACS version

GNU Emacs 24.4.1 (x86_64-w64-mingw32) of 2014-10-20 on KAEL

which comes with CEDET version

        Requested   File        Loaded
Package     Version     Version     Version
----------------------------------------------------------
cedet:      2.0     nil     ok
eieio:      1.4     nil     ok
semantic:       2.2     nil     ok
srecode:        1.2     nil     Not Loaded
ede:            1.2     nil     Not Loaded

Is this the best version to be using for java development? I can find no mention of javap in the code yet it is mentioned often in the various documentation sources.

EDIT:

I am in the process if rewriting malabar-mode which relies heavily upon CEDET. I am hoping to find the "correct" version so when malabar-mode is released, it will be based on the right CEDET.

1

My dev branch of CEDET has some extensions for better work with Java, like basic Maven & Ant support, etc. But it wasn't updated for at least a year - I plan to spend some time over the Christmas to sync it with current HEAD...

  • Thanks Alex. Is this the right one to base another package on? – M Smith Nov 24 '14 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.