1

I'm using helm-projectile in spacemacs. I want helm-projectile to ignore all the files in .stack-work directory when running helm-projectile-find-file.

I added .stack-work in projectile-globally-ignored-directories variable:

the result of C-h v projectile-globally-ignored-directories

But the result of helm-projectile-find-file still contains following:

result of SPC p f intero

All files in .stack-work were successfully ignored, except those 4 files. I cannot figure out why that 4 files are still showing up, while others don't.

I also tried to create.projectile in the root directory of the project with the following contents:

-/.stack-work

The result was, helm-projectile-grep seems to ignore .stack-work with .projectile. But there was no difference in helm-projectile-find-file; it still shows up that 4 files.

Why are that 4 files are showing up in the result? What should I do in order to completely ignore files in .stack-work?

1

if you want to use .projectile list of ignored files, you should try with

(setq projectile-enable-caching t)
(setq projectile-indexing-method 'native)

... inside your config file. It looks like ignoring by .projectile list is currently working with native indexing method. More details: in github . With alien method .gitignore is working well (but alien is not respecting .projectile list).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.