1

While trying to figure out another problem. I was advised to use the ivy-hydra package.

By default, it appears that ivy-hydra is NOT included with prelude-ivy. So I did a package-install ret ivy-hydra.

That seemed to install it, but then when I do a C-o I get a message saying

symbol's value as variable is void: ivy-preferred-re-builders

I have no idea how to move forward to resolve this. I guess it is something about regular expression builders? How does one correctly install ivy-hydra when working from a prelude-ivy install?

  • 1
    ivy-hydra is an official part of the swiper project but, just like swiper and counsel, is not installed along with ivy by default. This way, users can choose precisely which functionality they want installed. You can suggest the inclusion of ivy-hydra in the prelude-ivy module on Prelude's issue tracker. The error is likely due to stale packages; just try reinstalling ivy. – Basil Feb 13 '18 at 21:58
  • I had the same issue and managed to resolve it by installing the latest ivy package. – Indradhanush Gupta Apr 11 '18 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.