1

I currently have a strange behave when my code has comment on Spacemacs. Making it bad to read a file with a lot of comments

comments

Anyone knows how to change this behave? I tried to search about it and I failed.

Thanks a lot

0

I went to the comment line and enter M-x customize-face and changed the font-lock-comment-face with the same background used by the default lines.

| improve this answer | |
  • 1
    Carlos' solution worked for me. The background color in question for the default spacemacs configuration is #292B2E – Rainymood Sep 18 '18 at 17:33
0

I've gotten this to work in my config

(defun dotspacemacs/user-init ()
 (setq spacemacs-theme-comment-bg nil)
....
)
| improve this answer | |
  • Welcome to emacs.SE! Could you add a brief description of what it's supposed to do? Is the default value t? Are there other possible values? – JeanPierre Dec 30 '19 at 9:30
  • apparently it is set to a lighter color after the default bg is set. this setting negates the addition of the alternate bg this the comment text has a different fg color and the same bg as the rest of the buffer. Ihave found this to only really apply to the spacemacs theme. – Marty Buchaus Jan 9 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.