0

After a recent updates hebrew fonts have started to appear with squares around them

example:

Anyone know how to fix this? i tried changing to various fonts with no sucsess

this is my current font setup:

    ; fonts in linux
(if (string= system-name "zlap")
;(add-to-list 'default-frame-alist '(font . "Inconsolata-16"))
;(add-to-list 'default-frame-alist '(font . "Source Code Pro-18"))
;(add-to-list 'default-frame-alist '(font . "Pragmata Pro-19"))
;(add-to-list 'default-frame-alist '(font . "Fantasque Sans Mono 14"))
;(add-to-list 'default-frame-alist '(font . "monaco 19"))
;(add-to-list 'default-frame-alist '(font . "Office Code Pro-18"))
;(add-to-list 'default-frame-alist '(font . "Hack 19"))
;(add-to-list 'default-frame-alist '(font . " mononoki 19"))
(add-to-list 'default-frame-alist '(font . "fira mono 17"))
)

;; fontso in Win
;(if (system-type-is-win)
;(add-to-list 'default-frame-alist '(font . "Consolas-14"))
;)
(if (string= system-name "zbeast")
(add-to-list 'default-frame-alist '(font . "fira mono 23"))

)

  • Does this affect every buffer with Hebrew letters? – Wojciech Gac Feb 19 '18 at 15:28
  • thx for the response. this seems to happen in several buffers (org,elfeed,etc ) but i think its mainly in headers (org headers etc). the inline text seems to be presented ok – zeltak Feb 20 '18 at 5:46
  • Curious... I've tried Org-mode headers with Yiddish and the letters look normal - no squares whatsoever. My setting for default-frame-alist is STANDARD. Do you use the default version of Org-mode or the one from MELPA? – Wojciech Gac Feb 20 '18 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.