0

Been using Emacs 24 for more than an year, but not an expert. Following this answer I installed emacs25 from Kevin Kelly's repo. I haven't configured anything on this version yet and I still get an error message saying "Use font-lock-support-mode rather than calling lazy-lock-mode" every time I do M-x. Can someone explain this error and what to do about it?

I tried going to the customize menu and set value of font-lock-support-mode from "mode-specific" to "lazy-lock", but I couldn't save the changes beyond that session.

0

The message you cite indicates that you're somehow trying to use lazy-lock-mode, and the message is telling you not to (because it's obsolete since Emacs-22).

This use might be either in your ~/.emacs or in some other initialization file (see the (emacs)Init File node of the Emacs manual). E.g. you might find the site-file via M-x find-library RET site-start RET, same with the default file.

  • I don't understand how I'm using lazy-lock-mode. Fresh install, no init file, so how? – user128785 Feb 21 '18 at 9:47
  • Maybe a site-file? Try it with emacs -q and with emacs --no-site-file? Also do create your own ~/.emacs and put a (message "here I am") in it so you see in *Messages* if it comes before or after the "error". – Stefan Feb 22 '18 at 4:07
  • With emacs -q I got the error at every key press -- just as earlier. But magically (i.e. unknown to me) emacs --no-site-file worked, i.e. it loaded my .emacs that I used with version 24.5.1. So I didn't try the "here I am" message. Thanks, @Stefan! How can make this my default load setting? Could you point me to some blog post or relevant emacs help entry for --no-site-file? I am interested in learning. – user128785 Feb 22 '18 at 4:37
  • Stefan, I am accepting your answer, please add the tip that worked from the comment to the main answer. – user128785 Feb 22 '18 at 6:07
  • @user128785: --no-site-file is just a workaround. You need to find the corresponding site-file and fix it. I added some info about how to do that. – Stefan Feb 22 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.