0

I am trying to use Webkit, but I can't get emacs to find the necessary python library EPC that I installed via pip (in Anaconda). Here is the error message:

Debugger entered--Lisp error: (file-error "Cannot open load file" "No such file or directory" "epc")
  require(epc)
  eval-buffer(#<buffer  *load*> nil "/Users/evar/.emacs.d/myPackages/webkit.el" nil t)  ; Reading at buffer position 2348
  load-with-code-conversion("/Users/evar/.emacs.d/myPackages/webkit.el" "/Users/evar/.emacs.d/myPackages/webkit.el" nil t)
  require(webkit)

I am using High Sierra.

  • The mysterious "High Sierra" appears to be a version of Mac OSX. For future reference, people who don't use a Mac are unlikely to recognise names like that, so more clarity would be helpful. – phils Feb 21 '18 at 19:11
  • I strongly recommend to use xwidgets-webkit instead. – wasamasa Feb 21 '18 at 20:24
1

require(epc) in the stack trace indicates that epc.el is not found in your Emacs load-path variable.

You'll probably want to do something like:

(add-to-list 'load-path "/path/to/directory")

for the directory where epc.el lives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.