2

I'm using the auto-completion layer in Spacemacs with the following configuration:

(auto-completion :variables
                 auto-completion-return-key-behavior nil
                 auto-completion-tab-key-behavior nil
                 auto-completion-complete-with-key-sequence nil)

I'd like to not have auto-completion at all and instead just have snippets. Is there a way to disable the popup and in-place completion that comes with the layer while keeping snippets? Examples of the popup and the completion follow.

Popup. Completion.

It may not be clear from the completion pic but the "ass" part is added by the auto-completion layer.

1 Answer 1

0

You should be able to disable this behavior with the variable:

auto-completion-minimum-prefix-length

By setting it to some ridiculously high value, this effectively disables the pop-up.

auto-completion
         (auto-completion :variables
               auto-completion-minimum-prefix-length 30
               )

I can still call templates calling helm-yas (default: space i s) but I'm not sure if this breaks expansion in insert mode as I don't use it.

EDIT: I just learned this doesn't break snippet expansion in insert mode. M-/ calls Hippie-expand just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.