0

I've been using EMMS with mplayer for a couple days, and a minimal config:

(setq exec-path (append exec-path '("/usr/local/bin")))
(require 'emms-setup)
(require 'emms-player-mplayer)      ; load mplayer
(emms-all)
(emms-default-players)
(setq emms-source-file-default-directory "/Users/me/Music/iTunes/iTunes Media/Music/")
(emms-add-directory-tree emms-source-file-default-directory)

It worked very well, M-x emms would generate a buffer with the name of all files, and hitting RET would play it. However, for some reason, whenever I RET to play a song, an mplayer window pops up with the album cover, and when a songs end, this window pops up again showing the album cover for the next song. How can I remove this behavior and make emms as "silent" as possible? The album covers are embedded in the audio files.

Question: how to stop this popup window with the album cover?

3
  • Why do you use (emms-all) and not e.g., (emms-minimalistic) or just write your own config with the information from emms-setup.el.
    – Tobias
    Feb 28, 2018 at 18:28
  • Thanks for the suggestion! I wasn't aware of all those options! I found out that I can set mplayer options to be quite, and it seems to work (setq emms-player-mplayer-parameters '("-slave" "-quiet")) Feb 28, 2018 at 18:51
  • 2
    If those options work for you please answer your own question and accept your answer.
    – Tobias
    Feb 28, 2018 at 19:31

2 Answers 2

1

In my emacs26.2 use

(append emms-player-mplayer-parameters (list "-novideo"))

worked for me, however I think it's may disable the videoplay function.

1
  • after update, this answer no function and I use '(emms-player-mplayer-parameters (quote ("-slave" "-quiet" "-really-quiet" "-novideo"))) (first quote is essential) Sep 18, 2019 at 2:10
0

Following setting works for me in Mac with mplayer installed in /usr/local/bin

(use-package emms
:ensure t
:config
(setq exec-path (append exec-path '("/usr/local/bin")))

(emms-standard)
(emms-default-players)
(setq  emms-player-mplayer-parameters '("-novideo"))
)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.