0

I'm a bit lost on what I can use the TeX input mode for. What I'd like to achieve is a mathematical notation like ∑ᵢ₌₁ᴺ ∑ⱼ₌₁ᴹ in pure UTF text and it seems to mostly work, i.e. \sum _ i _ = _ 1 works, but \sum_t gives ∑ₜ which I guess means that the symbol _t is not supported by the current (what exactly?). When I try M-x describe-input-method Ret TeX I also see that _t is not supported. So, is this a limitation with a particular font, UTF itself, my computer or moon phase? And is there a solution? I tried both on my computer, with Mac OS X and a remote server, both seem to miss similar subscript letters.

  • The result of \sum_t that you've pasted here seems to include a subscript t (which is what I'd expect the output to look like). How does it look like in Emacs? Also, how does describe-input-method tell you that _t is not supported? – aplaice Mar 3 '18 at 16:40
  • yes, what I wan't is subscript t. Emacs shows me a box with four numbers inside, 20 on the upper and 9c on the lower. If I try to paste it here, it gives empty box. describe-input-method shows the same, that _t corresponds to a box with strange numbers inside. However, _i and _j are treated as proper underscores. – kakk11 Mar 3 '18 at 16:48
  • 209c (8348 in decimal) is the codepoint of the character subscript t, so Emacs correctly generates the character but just cannot display it. (In your question I see the copy-pasted subscript t correctly). The fault is (most probably) with the font. The solution would be to use a different font. It seems, though, that your browser has trouble displaying the characters as well. (For instance, view: en.wikipedia.org/wiki/… ). – aplaice Mar 3 '18 at 17:23
  • You can change the default font with M-x customize-face RET default RET. I don't know what fonts are available on your computer, so I can't make any real recommendations. – aplaice Mar 3 '18 at 17:29
  • 1
    @aplaiceThanks, the wiki link you showed has the similar problem displaying the subscript t. I've tried several fonts in Emacs now without luck and considering my browser has the similar problem, then I guess the problem is not Emacs related but something with system fonts instead. I do not seem to have DejaVu Sans Mono on my mac. – kakk11 Mar 3 '18 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.