Edit: I tried many themes and it was an issue for all of them so this is not a Zenburn specific issue.

Edit: Docker is not part of the issue as there is the same behavior when this is done using just emacs-nox.

Edit: In response to the comment from @caisah.
1) M-x version in emacs-nox outputs GNU Emacs 24.5.1 (x86_64-pc-linux-gnu) of 2017-09-12 on hullmann, modified by Debian.
2) I am running emacs-nox in LXDE terminal emulator version 0.2.0-1+deb8u1. I also tested it with lxterm and it is the same.
3) toggling full screen on and off and switching between maximize and iconify for LXDE terminal editor or lxterm did not make the black band at the bottom of the frame go away.

I am working on creating a emacs-nox development environment that works in a docker container. I have added the zenburn theme and followed the instructions to deal with the ugly terminal color issue here: https://github.com/bbatsov/zenburn-emacs#ugly-colors-in-the-terminal-emacs-version

In a docker container in emacs-nox zenburn is not being displayed the same way as in emacs (gui version). The last column on the second last row and all of the last row are black instead of the background color of the rest of it.

Here is what it looks like in a docker container in emacs-nox:

enter image description here

Here is what I would like it to look like without the black section at the bottom:

enter image description here

Note: This second picture is in emacs and I know it will not look exactly the same in emacs-nox. I would just like to get ride of the black section at the bottom and am showing this as counter example.

The relevant parts of the .emacs file are:

;; add zenburn theme
(use-package zenburn-theme
  :ensure t
  :pin melpa-stable)

;; add custom theme path
(add-to-list 'custom-theme-load-path "~/.emacs.d/themes/")

;; load zenburn theme on startup
(load-theme 'zenburn t)

The relevant parts of the Dockerfile are:

RUN echo "export TERM=xterm-256color" >> /root/.bashrc
  • I don't think this is a problem with the theme but rather with the terminal or emacs running in the terminal. If you exit full screen the black band will disappear. – caisah Mar 10 at 9:09
  • @caisah thanks for the comment. Toggling full screen off and on did not fix this. I added an edit to the question providing more information. – learningemacs Mar 10 at 16:48

Thanks to the comment @caisah provided I have been able to solve this issue. I discovered the solution by playing with guake as an alternative to LXDE terminal. It worked in right away with guake and the difference was that in the preferences for LXDE terminal I had the font size set to 20 while the default font size for guake was 10. I was able to get ride of the the issue with LXDE terminal as well when I also set the font size to 10.

Here is what emacs-nox with the Zenburn theme running in LXDE terminal looks like when I change the font size to 10 in it's preferences.

enter image description here

As you can see this solves the issue of the bottom of the frame being black. I can live with the last column of the last row being black.

However this solution brings up another issue about font size.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.