I've seen Manage same init file for Linux and Windows, but it is not quite what I want. Bear with the description of issues and my attempts for resolution.

I recently installed Emacs on Windows using emacs-25.3_1-x86_64.zip from the gnu ftp server, and did not install any other file. I found the init file .emacs, and the diretory .emacs.d in C:\Users\MyUSer\AppData\Roaming\ -- as the docs indicated. I copied my .emacs for emacs25.3 on Ubuntu 16.04 and the accompanying .dotemacs.org and pasted them in Roaming. I also pasted the org-dotemacs.el in Romaming\.emacs.d\. The contents of my init file are as follows:

 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
   [default default default italic underline success warning error])
 '(custom-enabled-themes (quote (wheatgrass)))
 '(initial-frame-alist (quote ((fullscreen . maximized))))
 '(package-selected-packages (quote (pdf-tools org-dotemacs))))
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.

(require 'package)

(add-to-list 'package-archives '("org" . "https://orgmode.org/elpa/") t)
(add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/"))
(add-to-list 'package-archives '("melpa-stable" . "http://stable.melpa.org/packages/"))

(setq package-enable-at-startup nil)

;;;;org-mode configuration
;; Enable org-mode
(require 'org)

(require 'org-dotemacs)
(load-file "C:/Users/MyUser/AppData/Roaming/.emacs.d/org-dotemacs.el")

The message I get is: Cannot open load file: No such file or directory, org-dotemacs. So I decided to look into the list of packages. Here I have another perplexing behaviour. The list loads, but I get errors contacting to org archive; output given below because I don't know if it is relevant to the problem mentioned ahead:

gnutls.c: [1] (Emacs) GnuTLS library not found
Opening TLS connection to `orgmode.org'...
Opening TLS connection with `gnutls-cli --x509cafile nil -p 443 orgmode.org'...failed
Opening TLS connection with `gnutls-cli --x509cafile nil -p 443 orgmode.org --protocols ssl3'...failed
Opening TLS connection with `openssl s_client -connect orgmode.org:443 -no_ssl2 -ign_eof'...failed
Opening TLS connection to `orgmode.org'...failed
Package refresh done
Failed to download `org' archive.
You can run the command `package-list-packages' with M-x pa-l- RET
Failed to download `org' archive.
Contacting host: melpa.org:80

Within the list of packages I find many with the label incompatible which is where I find org-dotemacs and on clicking it:

Status: Incompatible because it depends on uninstallable packages.
Archive: melpa

Version: 20151119.1022
Summary: Store your emacs config as an org file, and choose which bits to load.
Requires: org-7.9.3 (not available), cl-lib-1.0
Homepage: https://github.com/vapniks/org-dotemacs

The problem is in the Status and Requires fields, because I have org-mode, in fact M-x org-version gives Org-mode version 8.2.10 (release_8.2.10 @ c:/Users/MyUser/Downloads/emacs-25.3_1-x86_64/share/emacs/25.3/lisp/org/). I assumed something that needs org-7.9.3 would work with org-8.2.10.

What is wrong? Did I miss downloading some files from the gnu ftp server? Do I need to install some other software alongside for emacs to run properly on Windows? I can program but I am not a professional, I have somehow managed to use emacs on Ubuntu. I don't even understand how to run emacs with the --debug-init option on Windows.

  • Maybe, that answer resolves all your problems: emacs.stackexchange.com/a/27251/2370 Because of the TLS-problem you are currently working with GNU Emacs' own version of org which is known to be very outdated.
    – Tobias
    Mar 9, 2018 at 21:20
  • @Tobias I tried doing what you suggested. The files at that link are only available for emacs26 pretest but i nevertheless downloaded the one marked deps but it did not work -- I don't see the updated org in my package list. May be I should just delete the emacs25 installation and reinstallemacs26 with deps.
    – user128785
    Mar 22, 2018 at 9:57


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.