3

Trying to eww https://github.com on emacs -q with the following debug stacktrace:

Debugger entered--Lisp error: (error "Could not create connection to github.com:443")
  signal(error ("Could not create connection to github.com:443"))
  error("Could not create connection to %s:%d" "github.com" 443)
  url-http([cl-struct-url "https" nil nil "github.com" nil "/" nil nil t nil t] eww-render (nil "https://github.com/" nil #<buffer *eww*>) nil tls)
  url-https([cl-struct-url "https" nil nil "github.com" nil "/" nil nil t nil t] eww-render (nil "https://github.com/" nil #<buffer *eww*>))
  url-retrieve-internal("https://github.com/" eww-render (nil "https://github.com/" nil #<buffer *eww*>) nil nil)
  url-retrieve("https://github.com/" eww-render ("https://github.com/" nil #<buffer *eww*>))
  eww("https://github.com/")
  funcall-interactively(eww "https://github.com/")
  #<subr call-interactively>(eww t nil)
  elmacro-record-command(#<subr call-interactively> eww nil nil)
  apply(elmacro-record-command #<subr call-interactively> (eww nil nil))
  call-interactively(eww nil nil)
  command-execute(eww)

Mac OS version 10.11.6, GnuTLS 3.5.18 from Brew.

GNU Emacs 25.3.1 (x86_64-apple-darwin15.6.0, Carbon Version 157 AppKit 1404.47) of 2018-03-20

curl works fine, regular browser works fine, any other website through eww works fine.

For some reason, specifically github.com:443 with url-http.el library fails.

To be clear, I'm not trying to browse github.com in eww. However, tooling that relies on the same library as eww breaks in the same way as eww - I'm confident if I can figure out I'll fix the other.

Looking for any help on how to troubleshoot this.

3
  • I've flagged this question because of the down-vote without any comment. Maybe, the moderators can track down the people doing such thing. I also compensate that down-vote now with my up-vote. IMHO the question does not deserve a down-vote. The question is clear and even detailed information about the error, the system, and versions is given.
    – Tobias
    Mar 20 '18 at 14:31
  • My guess is the question is specific to my system. Which is the way to get downvotes on stackexchange sites since it tries to amass questions that apply to as many users as possible. However, I do not know where else it makes sense to post it. Mar 20 '18 at 17:02
  • Are you behind a proxy? It might help to run Wireshark and see where the connection fails (in the TLS handshake, or after). A tutorial on Wireshark is more than I can write in a comment. Mar 20 '18 at 23:21
3

It would seem that this version of Emacs(emacs-mac from Brew) and the latest version of gnutls from Brew are incompatible.

Installing emacs-plus solved issue for me.

1
  • dunno if there is a better fix or not, but that worked for me
    – tam5
    Jul 13 '18 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.