2

I have used customize-group on semantic to set global-semantic-idle-summary-mode to t. My .emacs has this entry in custom-set-variables : '(global-semantic-idle-summary-mode t).

However, on starting emacs and opening a C++ source file, I don't see the idle summary at point.
On disabling and re-enabling idle summary mode with two calls to M-x global-idle-summary-mode, the summary items start showing up.

How do I set this up correctly?

  • The custom setting itself does not load semantic. Some custom settings do, but their entry in custom-set-variables contains an additional reference to the required library. Maybe you need a (global-semantic-mode 1) in your init.el? – ChrisR Dec 2 '14 at 23:08
  • @ChrisR I don't see a customizable variable or a function called global-semantic-mode. In the semantic customization group, I see a bunch of global-semantic-*_modes. That's where I enabled summary-mode. – Pradhan Dec 2 '14 at 23:11
  • I'm not at my computer at the moment, so I can't check. Maybe it's called just semantic-mode. You could also try starting Emacs and doing C-h f global-semantic-idle-summary-mode. If it tells you that it's an autoloaded function, the problem is that the corresponding library is not loaded. – ChrisR Dec 2 '14 at 23:20
  • @ChrisR You are right - there is a semantic-mode. This is customizable as well and I have it set to t. – Pradhan Dec 2 '14 at 23:22
1

I also had this problem, then I updated it to latest bzr and the problem goes away. You can checkout the bzr version:

bzr checkout bzr://cedet.bzr.sourceforge.net/bzrroot/cedet/code/trunk cedet
cd cedet
make
cd contrib
make

Then load your Emacs with the new CEDET. You must load it at the very start of your init.el otherwise once the built-in CEDET is loaded, you won't be able to load the bzr version.

As for those global modes, they are actually minor modes and you have to enable it like this:

(add-to-list 'semantic-default-submodes 'global-semanticdb-minor-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-mru-bookmark-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-idle-scheduler-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-idle-summary-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-stickyfunc-mode)

(semantic-mode 1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.