I've downloaded and installed Emacs 24.1 on my PowerPC Mac and it works perfectly. And I've just added the Clozure CL to it and that works perfectly too using this tutorial. Now, I want to use SLIME. So I installed the SLIME package by:

  1. M-x package-install RET
  2. slime RET

SLIME seems to have installed itself into the directory ~/.emacs.d/elpa/slime-20141126.1323. So, I added the following code to my ~/.emacs:

(setq inferior-lisp-program "/Users/haansgruber/lisp/ccl-1.6/dppccl")
;; slime
(add-to-list 'load-path "Users/haansgruber/.emacs.d/elpa/slime-20141126.1323")
(require 'slime)

Then, restarted Emacs to see SWANK loaded SLIME but nothing happened. I entered:

M-x slime

But, this time it gave an error and fell back to inferior-lisp which is Clozure CL as shown below:

Emacs 24.1 PowerPC Mac

There must be some wrong lines on the .emacs config file. There are different .emacs conf lines available on the Internet and I tried several of them and they all ended up more or less with the same error, so I gave up. Could you help me find the solution?

  • 1
    This looks like the version of SLIME you are installing is older or in some other way incompatible with CCL version you have. I would ask on SLIME's mailing list what version should be used with what version of CCL. Usually, this isn't a problem but eventually a Lisp may add or remove a feature SLIME depends on and things like this happen.
    – wvxvw
    Commented Dec 4, 2014 at 7:02
  • Wait, what is even stranger is that SLIME tries to load a fasl with the code that gives this error... how did it manage to compile it in the first place? Can you try deleting (or just moving temporarily) ccl.dfsl and see if it will try to recompile it?
    – wvxvw
    Commented Dec 4, 2014 at 7:11
  • I am having the same problem you reporter about Slime with Clozure. I see that you have been able to solve it with sbcl. But how about Clozure? Have you been able to make it work with Slime? Thanks
    – user8434
    Commented May 27, 2015 at 12:13
  • On my OSX Lion, I use CMUCL because it works the best. On PowerPC Mac I keep on using SBCL. No luck with Clozure CL on OSX Lion or PowerPC Leopard.
    – Terry
    Commented May 28, 2015 at 20:05

2 Answers 2


SLIME from package-install can be finicky at times.


cd ~/git
git clone https://github.com/slime/slime


(add-to-list 'load-path "~/git/slime")
(require 'slime-autoloads)

After this, M-x slime. It will take a short time to compile before the first run. Try sbcl if Clozure doesn't work (I'm using sbcl and I just installed it on my laptop).

  • Thank you for the comment. However, it couldn't even load SLIME. Here's what I did: 'code' mkdir cd ~/git, mkdir slime, cd slime, curl -fsSLk github.com/slime/slime/tarball/master | tar xz -m --strip 1 and added the 2 lines you've given to ~/.emacs deleted the lines about SLIME. I have also uninstalled Emacs and installed it from scratch to remove the previous SLIME inst. Started Emacs and it gave this error on startup: File error: Cannot open load file, slime-autoloads Commented that line, restarted. M-x slime returned [No match]
    – Terry
    Commented Dec 3, 2014 at 22:42
  • The file needs to be at ~/git/slime/slime-autoloads.el. Is this the case?
    – abo-abo
    Commented Dec 3, 2014 at 23:13
  • After you mentioned the presence of ~/git/slime/slime-autoload.el, I've once more checked with it and noticed I've mistyped it on .emacs file. Corrected it and restarted Emacs. But again the familiar error came up, here's the screenshot.link
    – Terry
    Commented Dec 4, 2014 at 0:02
  • I've installed SBCL v1.0.47 (proper for PPC Mac) It installed itself into /usr/local/bin/sbcl so I changed the line to (setq inferior-lisp-program "/usrlocal/bin/sbcl") and restarted Emacs. Entering M-x slime returned: Process inferior-lisp not running. I might be missing some other declarative line for sbcl, I don't know.
    – Terry
    Commented Dec 4, 2014 at 0:35
  • What's wrong with Emacs 24.3 or 24.4? It could possibly have less problems by upgrading to those versions.
    – Tu Do
    Commented Dec 4, 2014 at 3:01

The solution that works starts off with the lines abo-abo has given, that is

downloading the SLIME package:

cd ~/git
git clone https://github.com/slime/slime

and adding these to ~/.emacs:

(add-to-list 'load-path "~/git/slime")
(require 'slime-autoloads)

and additionally add this line to ~/.emacs, assuming sbcl is installed into /usr/local/bin

(setq inferior-lisp-program "/usr/local/bin/sbcl")

If you only do the above, you end up with an Emacs running SLIME on the background. To have the SLIME come to the foreground you should add these lines to ~/.emacs

Source: franz.com/emacs/slime.lhtml

(eval-after-load "slime"
    (add-to-list 'load-path "/usr/local/slime/contrib")
    (slime-setup '(slime-fancy slime-banner))
    (setq slime-complete-symbol*-fancy t)
    (setq slime-complete-symbol-function 'slime-fuzzy-complete-symbol)))

Having added those lines, restarted Emacs and entered M-x slime I finally got what I wanted: Emacs Screenshot
(source: hizliresim.com)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.