1

I have tried doing this which I found in another StackExchange post but it doesn't work for me, is there another way to disable the mouse in spacemacs completely, I use evil mode, thanks.

How to disable mouse in Spacemacs

4
  • Can you just use github.com/purcell/disable-mouse as an additional package?
    – Ryan
    Apr 11, 2018 at 15:53
  • I have tried that. After installing disable-mouse the mouse was still being used by spacemacs. When I restarted spacemacs I saw a line stating: deleting disable-mouse. Mouse was still being used afterwards. @Ryan Apr 11, 2018 at 17:33
  • add it to dotspacemacs-additional-packages and make sure you have (global-disable-mouse-mode) in your configuration.
    – Ryan
    Apr 11, 2018 at 17:50
  • Where do I put (global-disable-mouse-mode), which file and what section? @Ryan Apr 11, 2018 at 18:00

1 Answer 1

1

Add the following to your dotspacemacs-additional-packages:

dotspacemacs-additional-packages '(
   disable-mouse
)

And put the following in the dotspacemacs/user-config section of your .spacemacs file:

(global-disable-mouse-mode)

That should disable the mouse for everything in Emacs.

4
  • I tried that on two different machines, mouse still works :( Apr 11, 2018 at 20:29
  • 1
    In the terminal (emacs -nw), I managed to do the trick by setting (xterm-mouse-mode -1) inside dotspacemacs/user-config.
    – Jir
    Sep 19, 2018 at 16:02
  • @Ryan I have tried the above but mouse still works, something else must be missing or I'm doing something wrong. Oct 25, 2018 at 16:59
  • This finally worked for me: (defun dotspacemacs/user-config () (xterm-mouse-mode 0) ) I got this from: emacs.stackexchange.com/questions/21540/… Jan 19, 2023 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.