5

Problem : I am using Emacs for general text typing and editing outside my Programming. This requires me to type in local languages of India ( specifically Hindi, Malayalam and Tamil ). I am on Fedora 27 that conveniently provides TypingBooster to all these languages in Input Methods. This works fine for all the applications, except Emacs. Emacs 25.3 however ignores system input method and forces me to use its input method. For example, when i try to type in Malayalam it only gives me two options : InScript and ITRANS . Both of which are less satisfactory to me than the Mozhi Input method which System provides. Unfortuately there seems to be no way for me to make Emacs just obey system input method /language and ignore its own language and input method setting.

Is there a way to do this ? I have tried change values in settings with no effect. Any guidance would be deeply appreciated as I would like to keep Emacs as my only text editor.

  • Since TypingBooster appears to use ibus, perhaps you need to install ibus.el and require it? Edit: this page indicates that you may need to also run (add-hook 'after-init-hook 'ibus-mode-on). – Bob Uhl Apr 12 '18 at 15:13
  • @BobUhl, Thanks for the suggestions. I followed them as listed in the page you linked. Sorry to say it has not helped. However, I am sure that its to do with IBus and Emacs. emacs-ibus project exists on Launchpad and Github. However the projects' last commit is in 2012. Outdated ? Any other way this could be achieved ? – dreaswar Apr 13 '18 at 17:23
  • Nope, I'm afraid I don't use a custom input method and that's all I could find for you. Sorry! – Bob Uhl Apr 13 '18 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.