1

Dear stackexchange users,

I would really appreciate your help in fixing my issue. I am new with centOS 7.0 with less a year of experience. I was using emacs-24.3 until the following error came up, so I compiled emacs-25.3 with source code. I tried to purge gtk without a success. This issue persists for weeks, and I really don't know what to do.

I would fully appreciate your help..

When I type emacs any.log the following Error shows up:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X protocol error: BadRequest (invalid request code or no such operation) on protocol request 130
When compiled with GTK, Emacs cannot recover from X disconnects.
This is a GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=85715
For details, see etc/PROBLEMS.
Fatal error 6: Aborted
Backtrace:
emacs[0x500792]
emacs[0x4e8659]
emacs[0x500823]
emacs[0x4b9dc1]
emacs[0x4bd945]
emacs[0x4bd9ce]
/usr/lib64/libX11.so.6(_XError+0x12b)[0x7fc8a5a6a07b]
/usr/lib64/libX11.so.6(+0x420d7)[0x7fc8a5a670d7]
/usr/lib64/libX11.so.6(+0x42195)[0x7fc8a5a67195]
/usr/lib64/libX11.so.6(_XReply+0x208)[0x7fc8a5a68088]
/usr/lib64/libX11.so.6(XQueryPointer+0x8e)[0x7fc8a5a5e0be]
/usr/lib64/libgdk-3.so.0(+0x4f80c)[0x7fc8a78a380c]
/usr/lib64/libgdk-3.so.0(+0x6ed9d)[0x7fc8a78c2d9d]
/usr/lib64/libgdk-3.so.0(gdk_window_get_device_position_double+0x12d)[0x7fc8a7895b0d]
/usr/lib64/libgdk-3.so.0(gdk_window_get_device_position+0x2d)[0x7fc8a7895bfd]
/usr/lib64/libgtk-3.so.0(+0x342c41)[0x7fc8a7e4ec41]
/usr/lib64/libgtk-3.so.0(+0x34312f)[0x7fc8a7e4f12f]
/usr/lib64/libgdk-3.so.0(+0x22338)[0x7fc8a7876338]
/usr/lib64/libglib-2.0.so.0(+0x4aeed)[0x7fc8a61d1eed]
/usr/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x159)[0x7fc8a61d14c9]
emacs[0x5c8c18]
emacs[0x5966b1]
emacs[0x4f2c8d]
emacs[0x4f492f]
emacs[0x4f6446]
emacs[0x557d0d]
emacs[0x4e8b8c]
emacs[0x557cbb]
emacs[0x4e8b47]
emacs[0x4ecf74]
emacs[0x4ed295]
emacs[0x417318]
/usr/lib64/libc.so.6(__libc_start_main+0xf5)[0x7fc8a1eaac05]
emacs[0x417e1c]
Aborted (core dumped)
2

This looks to be a known GTK+ bug. It appears from [https://bugs.launchpad.net/elementaryos/+bug/1355274](this discussion) that running emacs with XLIB_SKIP_ARGB_VISUALS=1 in your environment will fix it.

You can try it by running XLIB_SKIP_ARGB_VISUALS=1 emacs any.log.

You could also try rebuilding emacs and calling configure with --with-x-toolkit set to something like athena or no. I tried it with both athena & no, and either option resulted in a perfectly decent-looking emacs. The menu & tool bars (and I assume scrollbars too — I didn't check those) are subtly different, but still quite usable. Many folks disable them anyway!

  • You are so awesome. Thank you very very much! It is fixed. I will remember and pass on if any people have the same issue. Awesome! – Tony Cho Apr 12 '18 at 16:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.