I can compile Emacs 26.1 RC1 ok, and use it locally on the host fine.

However, when attempting to ssh -X to host via PuTTY 0.70 and launch the Emacs gui, emacs is not displaying correctly. See screenshot below - no default welcome screen, and missing minibuffer too. Using Windows xserver program VcXsrv (

Emacs 26.1 RC1 GTK3 display issue

I suspect this issue is related to some combination of GTK and Xming/VcXsrv, however the behavior does change between Emacs 25.3 and 26.1 RC1, see table below:

| emacs    | x-toolkit | result
| 26.1 RC1 | gtk3      | bad
| 26.1 RC1 | gtk2      | bad
| 26.1 RC1 | motif     | ok
| 25.3     | gtk3      | ok
| 25.3     | gtk2      | ok
  • emacs -Q produces the same result.
  • freshly compiled on Opensuse Leap 43.2 and CentOS 7 produces same result
  • XLIB_SKIP_ARGB_VISUALS=1 emacs same result

./configure options I ultimately desire:

--with-x-toolkit=gtk3 --with-xwidgets --with-modules --with-mailutils

Where gtk3 is required for xwidgets, so motif or other x-toolkits are not the best solution.

Note: with Xming (not vcxsrv) I get core dumps with error messages referencing this GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=85715

Can anyone else replicate this problem or have any ideas how to resolve?

wget ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-26.1-rc1.tar.xz
tar -xvf emacs-26.1-rc1.tar.xz
cd emacs-26.1
./configure --with-x-toolkit=gtk3 --with-xwidgets --with-modules --with-mailutils --prefix=/home/test/emacs_26.1_gtk3
make && make install 
# launch emacs, confirm ok
# login to windows, launch ssh -X putty session to linux host, + vcxsrv/xming
# launch emacs - compare to screenshot


  • 1
    Please, please, pretty please M-x report-emacs-bug rather than send such things here! Please! Release candidates (and beta-releases as well) aren't there for users to play with it and discuss problems among themselves, but so that such issues are reported to the maintainers so they can hopefully fix them before the release.
    – Stefan
    Apr 15, 2018 at 19:44
  • Submitted. Will post link when accepted
    – bscipio
    Apr 15, 2018 at 22:16
  • I also reproduced on OpenSUSE Tumbleweed w/GTK+ Version 3.22.29
    – bscipio
    Apr 16, 2018 at 0:22
  • 1

1 Answer 1


Emacs 26 by default switches on double buffering for X servers when it finds the Xdbe header on the build machine. (See Emacs 26 release notes at the GitHub mirror.) Some X servers don’t support this.

Therfore switching off double buffering by adding '(inhibit-double-buffering . t) to your frame parameters might fix this. Safest way is to add it to default-frame-alist:

(setq default-frame-alist
         (append default-frame-alist '((inhibit-double-buffering . t))))

Credit: This tip comes originally from the bug-gnu-emacs list. (Thanks Eli and Robert!)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.