2

I am attempting to use a plain TeX format, say, foo.fmt (which is findable with kpsewhich), with Emacs/AUCTeX (actually Aquamacs with built-in AUCTeX). I'm unable to get AUCTeX to recognize the custom format. In TeXShop (a Mac TeX frontend) I would simply say at the top of the file:

% !TS-program=foo

In Emacs, I have tried various "Local Variables" such as

%%% Local Variables:
%%% TeX-engine: foo
%%% End:

followed by C-c C-n. C-c C-c returns an error indicating that the .fmt file has not been used. What am I missing?

2

I can't test this without your foo.fmt file, but I think you need to set this using the variable TeX-command-extra-options:

%%% Local Variables:
%%% TeX-command-extra-options: "--fmt=foo"
%%% End:

I'm not sure of the syntax, maybe it should be --fmt=foo.fmt instead.

  • The format should indeed be -fmt=foo.fmt. That worked perfectly. Thanks! – sgmoye Apr 18 '18 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.