3

I am getting this error "defconst: Symbol's value as variable is void: org-list-allow-alphabetical" while starting org2blog. I see the issue is that the builtin org-mode which is installed with emacs is org mode version 7.9.3, while I installed the org2blog mode from mepla and it installed a newer org mode version.

My question is how I can use the newer installed version instead of the inbuild org-mode.

  • Did you do a package-initialize before starting org2blog? Packages should appear in-front of built-ins in the load-path. – stsquad Dec 4 '14 at 11:11
  • yup tried doing that got the same error. – OmPS Dec 4 '14 at 11:21
  • can you dump your load-path somewhere (pastebin)? – stsquad Dec 4 '14 at 11:23
  • pastebin.com/46MjEg5k – OmPS Dec 4 '14 at 11:29
  • 2
    The built in org release is getting initialized before the new release. This page explains the autoload behavior orgmode.org/manual/Installation.html – grettke Dec 5 '14 at 0:59
-1

I believe that you can add the following at the end of your init file to ensure that the latest version of org-mode is loaded.

(mapc #'require '(org-version org))
| improve this answer | |
  • This doesn't solve the issue, it just makes sure that these libraries get loaded. The issue isn't that they don't get loaded, but that the wrong versions get loaded. – tarsius Dec 27 '14 at 18:06
  • @tarsius, I understand your point. Even if it's not the right solution, I had the same issue and the above code did force the org version from package.el code to get loaded (when at the end of my init file). – rimero Dec 27 '14 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.