I am using Spaceline with the following configuration:

(use-package spaceline-config
    mode-line-format '("%e" (:eval (spaceline-ml-main)))
    powerline-default-separator 'wave
    spaceline-flycheck-bullet "❖ %s")
      (version-control :when active)
      (projectile-root :when active)
    '((remote-host :when active)
      ((flycheck-error flycheck-warning flycheck-info) :when active)
      (major-mode :face highlight-face)
      (("L" line column) :separator ":"))))

However there is some interference between the mode-line and Spaceline, causing an overflow effect. I've tried using Powerline, patching fonts and fiddling with the powerline height, but that doesn't seem to help.

spaceline overflow

This is on the Macports version of Emacs 25 on macOS. Font is Fira Mono.

2 Answers 2


Powerline (and thus spaceline) inherits font properties from the fonts mode-line and mode-line-inactive. At one point these fonts must have added an underline, visible in the image by this ugly grey line.

The solution (setq x-underline-at-descent-line t) proposed before fixes the issue by moving the underline "out of the way". Unfortunately, it places all your underlines at the descent line which is ugly.

I suggest to instead solve this issue by customize-face RET mode-line and customize-face RET mode-line-inactive and in each dialog setting :underline nil


This fixed the problem for me:

(setq x-underline-at-descent-line t)
  • 2
    You might want to explain how/why this fixes the problem. You might want to show what C-h v presents for this variable.
    – Drew
    Mar 15, 2019 at 0:40
  • Fixed it for me as well. I don't think anybody wants to try to understand how the position of the underline breaks the spaceline.
    – HRSE
    Jan 15 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.