0

I've been having some problems when using org inside spacemacs. I make use of org-protocol to capture stuff that I find interesting when I'am browsing and have it inside spacemacs. The problem is that I can't seem to get it this process to work flawlessly. Sometimes everything works fine but other times instead of opening the capture inside spacemacs I get No server buffers remain to edit and a new browser window pops up. Othertime I get Error (use-package): org-projectile/:config: Symbol’s function definition is void: org-projectile:per-repo and once again a new browser window pops up.

In my .spacemacs file I enabled the org layer and in user-config I have the following:

  (server-start)
  (use-package org-capture
    :bind ("<f8>" . org-capture)
    :after org)

  (use-package org-protocol 
    :after org)
  • Have you enabled org-protocol in org-modules? You can do this via M-x customize-group RET org RET or put the following in your init file: (setq org-modules (quote (org-protocol))) – mclear May 10 '18 at 0:28
  • @mclear I didn't but having done that it's now working normally. How did you know to do that? I didn't see any reference to org-modules in the documentation for org-protocol (to be honest I wasn't even aware that was a thing). – plx May 10 '18 at 20:10
  • org-protocol is one of the ones listed in the module customize group. I then just looked at the code that was put in my custom.el file and went from there. There are some alternatives for listing modules described here. Should I put this as an answer to your question then? – mclear May 11 '18 at 2:53
  • Yes, go ahead. I feel this is something other people may end up having trouble with in the future. – plx May 11 '18 at 6:51
0

You should enable org-protocol in org-modules. You can do this via M-x customize-group RET org RET or put the following in your init file: (setq org-modules (quote (org-protocol))). There are also some other ways to enable modules as detailed here.

0

Just inserting org-protocol into org-modules did not work for me, what helped was adding a require:

(defun dotspacemacs/user-config ()
  (require 'org-protocol)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.