5

I'm struggling to get type checking working in spacemacs, and I would appreciate any help. I've installed MyPy properly on my system (I can run it from terminal) and added python-mypy to dotspacemacs-additional-packages, and if I run flycheck-verify-setup (M-m e v) python-mypy is listed there with the correct path to the executable (it's not disabled either). However, I still don't get an error even if running mypy from the terminal does produce an "incompatible type" error.

Any hints as to what I'm missing?

3

In case anyone else struggles with this, simply doing pip install flake8-mypy did the trick for me.

  • This seemed to do the trick in normal emacs for me too! – n1k31t4 Jun 28 '18 at 23:44
  • For support for plain mypy integration look here. – thinwybk Jan 5 at 18:46
  • I added python-mypy to dotspacemacs-additional-packages but got Package python-mypy is unavailable. Is the package name misspelled? – thinwybk Jan 5 at 18:57
0

I added flycheck-mypy to dotspacemacs-additional-packages

dotspacemacs-additional-packages
'(
  flycheck-mypy
  )

and enabled it in user-config (python-flake8 is required)

(defun dotspacemacs/user-config ()
  (require 'flycheck-mypy)
  (flycheck-add-next-checker 'python-flake8 'python-mypy t)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.