1

(Manually moved by copy/pasting from this Unix SE deleted question)

I'm debugging my MELT monitor, in relation with MELT (a domain specific language & meta-plugin to extend & customize the GCC compiler).

I'm using emacs24 (24.4.1) on Debian/Sid/x86-64 with its gdb-mode; most often, I am typing gdb commands in the *gud-monimelt* emacs "window" (inside an emacs frame which is a toplevel window for my LXDE window manager).

I can't get rid of an annoying behavior; after every successfully typed gdb command (e.g. bt, or print ...) , the *gud-monimelt* emacs "window" is undisplayed or deleted (as if I typed Ctrl-X 0) and I have to type again Ctrl-X b *gud Tab to get it back.

FWIW, gdb is version 7.7.1 (but with a GDB 7.8 from Debian/Experimental the same is happenning).

I'm getting the same annoyance on every computer I'm using (and also on emacs-trunk 25.0.50.6 compiled daily from the latest emacs .git). My .emacs is quite small and has no occurrence of gud or of gdb

Do you know any setting to remove this automatic undisplay? I have several emacs frames and several emacs "windows" within my emacs session, and I don't want GUD to close automagically any emacs windows.

  • Can you add a minimal example? Just a single small C file, minimal Emacs config and sequence of actions to reproduce the bug. – abo-abo Dec 5 '14 at 11:43
  • It probably would take me an hour of work, so I'll do that later (this evening). Do you know how to log every keystroke? – Basile Starynkevitch Dec 5 '14 at 11:52
  • 1
    You could do with edit-named-kbd-macro, I guess. But it should not be necessary as the sequence probably is just gdb, gud-break, r, bt. – abo-abo Dec 5 '14 at 11:59
  • I am not using gud-break; I am typing commands to gdb – Basile Starynkevitch Dec 5 '14 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.