0

I'm having quite a bit of trouble getting use-package to automatically install packages in emacs27

I deleted a package using package-delete and restarted emacs. On emacs26, use-package would automatically install the package by connecting to MELPA. But on emacs27, I'm getting the below error:

Error (use-package): Failed to install anzu: package.el is not yet initialized!
Error (use-package): Cannot load anzu
Warning (initialization): An error occurred while loading ‘/Users/csraghunandan/.emacs.d/init.el’:

error: package.el is not yet initialized!

Here is my emacs configuration Anybody know how I can fix this issue? Is there anything I need to add to my early-init.el file?

0

You should report this upstream: the early init of package.el should have taken care of that, so this seems like an upstream bug. That error comes from package.el itself, originally, simply triggered by use-package interacting with the public interface of the package system.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.