0

The first post-installation task in magit manual is to check the version:

M-x magit-version RET

This gives the error:

require: Symbol’s value as variable is void: git-commit-mode-map

Predictably, so does running:

M-x magit-status RET

Google search on this error turned up nothing. I already tried uninstalling magit, restarting emacs, re-installing, and restarting again.

Can anyone help?

  • I have the latest version of magit installed (20180522.507) as available from MELPA. – polsar May 22 '18 at 19:48
  • Is git-commit installed also? – tarsius May 22 '18 at 20:10
  • Ensure that the file that defines git-commit-mode-map is loaded before the require sexp that tries to use its value. – Drew May 22 '18 at 22:36
  • @tarsius Yes, git-commit is installed. – polsar May 23 '18 at 0:10
  • @Drew I don't understand what you mean. Do I need to have some magit-specific stuff in .emacs file? – polsar May 23 '18 at 0:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.