I'm trying to set up flycheck to run flake8 on my python files. I'm using pipenv so I set up flycheck-python-flake8-executable for my buffer to point to the virtual environment version of flake8 and it seems to be detected. However it refuses to enable the checker. Running flycheck-verify-setup gives me

  python-flake8 (disabled)
    - may enable:         yes
    - executable:         Found at /Users/gmauer/.local/share/virtualenvs/project-name-qFaGhtMo/bin/flake8
    - configuration file: Not found

So I try to enable it with flycheck-disable-checker and...nothing, nothing output to messages, no errors, same verify-checker output.

I thought that maybe it has to do with the fact that it can't find a configuration file but I have a valid .flake8 file in both my user root and in my project so I have no clue why its not detecting it.

exclude = .git,__pycache__,docs/source/conf.py,old,build,dist,node_modules,instance

I can run it just fine from eshell.

What could be wrong? What else do I do to debug?

  • do you enable flycheck-mode or have a hook for enabling it on .py files in your .emacs? Commented May 26, 2018 at 21:08
  • @manandearth yes, flycheck-mode is enabled and showing up as enabled. I've also tried toggling it Commented May 27, 2018 at 15:45

1 Answer 1


You can set the path to your flake8 configuration with: (setq flycheck-flake8rc "/path/to/your/flake8-config-file")

As for enabling there are different ways of doing it I prefer to use an add-hook like so: (add-hook 'python-mode-hook 'flycheck-mode)

You can also set it up globally with: (add-hook 'after-init-hook #'global-flycheck-mode).

  • 2
    Cool, thanks, got that set, and I do have flycheck enabled and am trying to enable the checker but it never seems to get enabled. When I select it directly it just says Flycheck cannot use this syntax checker for this buffer. I do see an issue on their tracker about this now that I've gotten past this point github.com/flycheck/flycheck/issues/1437 Commented May 27, 2018 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.