1

I am on MacOS High Sierra, iterm2; I cannot find how to display images in org-mode. My term supports image display as imgcat works well within my shell. When I try to open the image link in emacs it returns Display not supported then the verbose is gibberish. I don't want use GUI emacs. I have tried to install Spacemacs but it does not solve the issue. I have tried to turn on iimage, imageMagick without luck. Any idea?

  • It is likely that emacs does not support iterm2's proprietary image format. – amitp May 29 '18 at 19:24
  • Emacs is supposed to support jpg/png format, isn't it? – Holzy Corp May 29 '18 at 20:40
  • Emacs does support jpg/png. It knows how to read those files and turn them into pixel data. And it knows how to draw them to a GUI. What you're asking for is for Emacs to know how to draw them to iterm2's proprietary format, and I don't think Emacs has code for that. Emacs has code for terminals, but not specifically for iterm2's features. – amitp Jun 9 '18 at 16:21
  • You are right. No way to display an image in emacs on os x, outside emacs GUI, which is actually good! – Holzy Corp Jun 13 '18 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.